MT7688如何配置wireless文件连接WiFi



  • 想打开WiFi功能,在阅读官网中的指导信息后,修改了wireless文件,重启服务,输入ap_client命令,显示为no,请指导下错误原因。贴下wireless和network的内容
    wireless如下

    config wifi-device 'radio0'
    	option type 'ralink'
    	option variant 'mt7628'
    	option country 'CN'
    	option hwmode '11bgn'
    	option htmode 'HT40'
    	option channel 'auto'
    
    config wifi-iface 'ap'
    	option device 'radio0'
    	option network 'lan'
    	option ifname 'ra0'
    	option ssid 'Widora-15E8'
    	option encryption 'none'
    	option hidden '0'
    	option mode 'sta'
    	option disabled '1'
    
    config wifi-iface 'sta'
    	option device 'radio0'
    	option disabled '0'
    	option mode 'sta'
    	option network 'wan'
    	option ifname 'apcli0'
    	option ssid 'tlink_ap'
    	option key 'nan123456'
    	option hidden '0'
    	option encryption 'psk2'
    
    

    network如下

    config interface 'loopback'
    	option ifname 'lo'
    	option proto 'static'
    	option ipaddr '127.0.0.1'
    	option netmask '255.0.0.0'
    
    config globals 'globals'
    	option ula_prefix 'fd5c:2322:f0e5::/48'
    
    config interface 'lan'
    	option force_link '1'
    	option macaddr '0c:ef:af:d4:15:e9'
    	option type 'bridge'
    	option proto 'static'
    	option ipaddr '192.168.8.1'
    	option netmask '255.255.255.0'
    	option ip6assign '60'
    	option ifname 'eth0'
    
    config interface 'wan'
    	option force_link '1'
    	option ifname 'apcli0'
    	option macaddr '0c:ef:af:d4:15:e8'
    	option proto 'dhcp'
    
    config interface 'wan6'
    	option proto 'dhcpv6'
    
    config switch
    	option name 'switch0'
    	option reset '1'
    	option enable_vlan '0'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '1'
    	option ports '1 2 3 4 6t'
    
    config switch_vlan
    	option device 'switch0'
    	option vlan '2'
    	option ports '0 6t'
    
    config interface 'wwan'
    	option proto 'dhcp'
    	option ifname 'apcli0'
    
    


  • wan部分的macaddr、force_link都去掉后,重启网络


Log in to reply
 

9
Online

982
Users

583
Topics

2.3k
Posts