OpenWrt18.06 + mt76 master driver 简单测试



  • 测试了一天,wifi使用ap+sta模式,一台手机播放视频,一台ipad刷剧,两台电脑(一台刷剧,一台上网下载)。持续6个小时。网卡流量:

    wlan0     Link encap:Ethernet  HWaddr 0C:EF:AF:D2:86:B2  
              inet addr:192.168.123.23  Bcast:192.168.123.255  Mask:255.255.255.0
              inet6 addr: fe80::eef:afff:fed2:86b2/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:12089085 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6730602 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:16473992926 (15.3 GiB)  TX bytes:995973879 (949.8 MiB)
    
    wlan0-1   Link encap:Ethernet  HWaddr 0E:EF:AF:D2:86:B2  
              inet6 addr: fe80::cef:afff:fed2:86b2/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:5671077 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8712233 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:507475582 (483.9 MiB)  TX bytes:14895829937 (13.8 GiB)
    

    初步感觉稳定性不错,以前烦人的crash没有出现



  • 以前是什么样的crash ?

    18.06是刚这两天发布的吗?



  • 今天刷了21小时,流量20GB
    IMG_0687.jpg



  • 大约36小时,41.5G。其中AP走了14.6G,剩下的是有限网口。上行是STA。
    EC5CF58D74FF9162ED3A235714A2371F.jpg



  • 请问如何配置mt76?



  • @liquanqing 指的编译配置还是运行时的配置?



  • 编译,编译我打开了kmod-mt76,然后更新固件后,连iwconfig命令都没有,不知道需要哪些依赖,希望能说下。



  • @liquanqing 如果是18.06编译仅仅是打开kmod-mt76即可。
    配置命令接口试试iw



  • @mangogeek 我测试的MT76包如下:
    +PKG_SOURCE_DATE:=2018-12-31
    +PKG_SOURCE_VERSION:=7d4a95c8ddf8c775ee387ae0ddecf297d6c27ee0
    可能涉及到修改Openwrt18.06的package/kernel/mt76/Makefile



  • @mangogeek 使用iw能连接上,作为sta,请问有没有详细设置的相关资料可以提供学习?



  • 我一般是直接编辑network和wireless文件:
    network增加如下:
    config interface 'wwan'
    option proto 'dhcp'

    wireless的sta修改:
    config wifi-iface 'default_radio1'
    option device 'radio0'
    option network 'wwan'
    option mode 'sta'
    option ssid 'ssidssid'
    option encryption 'psk2'
    option key 'keykeykeykey'

    改后重启网络一般就可以了



  • openwrt原版的luci也能操作



  • @neige 可以,安装opkg的luci即可



  • @mangogeek said in OpenWrt18.06 + mt76 master driver 简单测试:

    启网络一般就可以了

    谢谢,按照方法成功了,请问一下,ap模式怎么配置,使用WWIDORA_NEO-32的dts配置,以下下是network和wiress的配置:
    root@OpenWrt:/overlay/upper/etc/config# cat network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd14:478b:c323::/48'

    config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

    config device 'lan_dev'
    option name 'eth0'
    option macaddr '0c:ef:af:d1:dc:fa'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '0'
    root@OpenWrt:/overlay/upper/etc/config# cat network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd14:478b:c323::/48'

    config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

    config device 'lan_dev'
    option name 'eth0'
    option macaddr '0c:ef:af:d1:dc:fa'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '0'



  • 其实你现在可以用luci来设置wifi模式了



  • 现在开源的7628驱动性能也很好了嘛?能达到你们优化的效果百分之多少呀?



  • @hylon 我们私有驱动7688单天线测试吞吐110Mbps, 当时的mt76开源记得可以达到70-80M
    听说现在mt76的性能比之前更好, 最近还没时间review



  • @mangogeek 谢谢哈,想买你们的做产品,但是你们的没4G成品,你们怎么不做那种类似diy组合比较方便的方案?我们小公司不做硬件,想搞一个4G的好难呀,之前找了一个4G产品,感觉他家硬件太差,总是断流。你这边有没有推荐的你们的客户做这个的呢?



  • @hylon 7688群里很多都是做4G路由器的, 你可以进去看看
    299381903



  • @mangogeek 非常感谢!


Log in to reply