怎么配置网络模式



  • 想让模块作为一个客户端使用,不需要路由功能,关闭模块的wifi热点。
    需要通过有线和无线连接到路由,有线无线同时存在时,优先使用有线。有线通过dhcp自动获取ip地址。

    修改/etc/config/network 中的设置,把eth0的配置改成dhcp,删除option type 'bridge' 插上网线后可以正常上网。但是再使用widora_mode命令连wifi就连不上了,需要把原先的配置还原。

    我需要怎么配置才能达到上面的要求,如果改配置不行要修改代码要怎么改



  • 我的需求跟你的类似,考虑用VLAN做多WAN应该是靠谱的吧


  • administrators

    这样试一下看是否可行:
    1、默认固件,恢复出厂设置。
    2、widora_mode client模式,此模式下,AP是hidden的,AP不能关,否则sta也就不工作了。
    3、修改/etc/config/network文件,在wan域会找到apcli0,此名字前添加eth0,类似这样子:
    option ifname 'eth0 apcli0'
    4、nr命令重启网络



  • wan域 ifname 增加 eth0 ,网线和wifi同时连是可以上网的,但不知道是通过wifi还是有线联网
    插上网线后会不停的打印 br-wan: received packet on eth0 with own address as source address
    模块开启udp服务会不停的重复的收到,只连wifi udp服务是正常的


  • administrators

    @zhaojie 对于一个正常的PC来说,有线无线同时连上,是看的哪个能获取到网关IP和DNS依靠哪个上网。
    如果有选择的情况,我估计要写个脚本专门判断才行。



  • @mango 0_1518083070175_ec4bc28b-d215-496a-876e-7ab185f2e671-image.png

    这样设置有线和无线通同时连上,路由上能看到2个mac地址,ifconfig也能看到有2个ip地址,但数据应该是通过先连上的那个发送的,拔掉网线后网络会有问题,要重启网络。


  • administrators

    @zhaojie 不对,你的eth0怎么跑到了lan里?且lan怎么是dhcp?



  • @mango eth0默认是在lan里 dhcp是手动改的。 改成wan也不行 ifconfig apcli0 down 禁用无线网卡后 ping显示目标不可达。



  • @mango eth0不能设置成 wan 设置成wan之后 就会不停的打印
    received packet on apcli0 with own address as source address

    ifconfig apcli0 down 禁用网卡后过一会自己又重新连上了,这个怎么去掉



  • 配合mwan3能不能解决你的问题? @zhaojie



  • @ahejn said in 怎么配置网络模式:

    mwan3是啥



  • 把eth0 那里的lan 改成wlan0 基本正常

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd13:685e:e7c5::/48'

    config interface 'wan0'
    option ifname 'eth0'
    option proto 'dhcp'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '0'

    config interface 'wan'
    option ifname 'apcli0'
    #option type 'bridge'
    option proto 'dhcp'

    http://ju.outofmemory.cn/entry/125123

    但是还有问题,先连有线,然后把网线插上,这时候有2个网卡,如果其中有一个断开,另外一个可以正常工作,但拔掉网线以后,模块ping本地局域网不通,本地局域网电脑ping模块能通。需要重启网络


  • administrators

    @zhaojie 你已经全改乱了吧,LAN域都给删掉了?



  • @mango 应该可以不需要lan 因为只用一个网口



  • 你的问题解决了嘛?



  • @wateras 改了默认的网络配置文件 加了自动切换的python脚本就可以了



  • @zhaojie 这个路由表的问题,插上网线 router命令可以看到路由表变了,但拔掉网线后eth0的路由还在,导致wifi不能上网。写一个程序发现网络连接状态改变后,修改路由表就可以了。



  • @zhaojie 可以分享你的配置方法和脚本嘛?也想实现类似PC电脑功能,有线无线插上都可以上网,优先选择有线或者最先获取到IP的联网方式,其中一个失效,另外一个上网不受影响。


Log in to reply