ssh and upmpcli problem

  • Hello Mango,

    I have a problem with my openwrt configuration.

    First problem: I can't reach my widora neo through ssh when connected with the lan port to my router. I changed the network configuration for the lan port to dhcp so it receives a IP from my router, but I can't ssh into it.

    Second problem: I want to reach upmpcli through my home wifi. So when the widora neo is plugged in the home router through ethernet, But upmpcli is not broadcasted through my home router. I tried different interfaces in the upmpcli config, but only the original setting of br-lan works and broadcast through the widora wifi.

    In my finished project I don't need the wifi, only the lan. So I want to disable the wifi. But somewhere it seems connection through lan is blocked as upmpcli and dropbear aren't reachable through the lan port.

    By the way, any change on a openwrt trunk version, so squeezelite is also available thought the openwrt repo?

  • Looks like a firewall issue, but I have to look at your /etc/config/network file.

  • Dear Mango,

    This is my current /etc/config/network:

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr ''
    option netmask ''

    config globals 'globals'
    option ula_prefix 'fdd7:5048:aea1::/48'

    config interface 'wan'
    option ifname 'eth0'

    option macaddr '0c:ef:af:d0:13:4b'

    option proto 'dhcp'

    option ip6assign '60'

    I already tried different version without succes. I disabled also the firewall:

    /etc/init.d/firewall stop
    /etc/init.d/firewall disable

    What I want to achieve is that the widora works as a client on the system so not as a router, but in fact as a regular pc. I want to reach it over the network through ssh and it should work with upmpcli as a pnp renderer and with squeezelite as a squeezebox client connected to my amplifier (old Kenwood KR5400).

Log in to reply